
Phone  (321) 888-2288

Email: info@packetiq.com

 www.packetiq.com

Wireshark User Interface Elements Wireshark v1.10 Frame vs Packet vs Segment

A frame is the entirety of the data package from the

start of the Media Access Control (MAC) layer header

(such as in an Ethernet header) to the end of the MAC

trailer (Frame Check Sequence)(not always counted)

A packet is the payload of the frame minus the MAC 

header/trailer (Ethernet frame, for example)

To help remember the difference : a router strips off

the previous Ethernet frame, internally routes the 

packet to the proper egress port, and wraps it in a

new Ethernet Frame header/trailer (with different MAC

layer addressing & FCS) for transmission

A segment is the payload contents following the TCP 

header - the application payload. The max size of this 

payload is the Maximum Segment Size (MSS)

1. Title (trace file name) 2. Menu 3. Main Toolbar

4. Display Filter Toolbar 5. Wireless Toolbar 6. Packet List Pane IP and UDP packets carry datagrams vs segments

7. Packet Details Pane 8. Packet Bytes Pane 9. Status Bar

Features & Functions:   File & Edit Wireshark Configuration Profiles
File Menu > Open (Ctrl O) - browse for capture files Edit > Configuration Profiles… Create, copy, delete,

File > Open Recent - quick load of previous files Export Specified / Dissections Options: or select custom

File > Merge - merge 2 or more capture files Export Specified Packets Captured or Displayed configuration profiles

File > Save As .pcap or pcap.ng

File > File Set > List Files Packet Range options Wireshark settings

Select from list of long-capture files Range 4-  or  4-63 are saved in profiles

File > Export Specified Packets Range 1,5,6-9 There are global and

Export filtered / displayed packets to a new file custom profiles, and

Export Packet Dissections you can create a set

File >Export Packet Dissections Marked / Ignored Pkts of custom profiles

Export to .csv or other formats for multiple analysis

File > Export Objects - save Packet summary line: environments

HTTP / DICOM / SMB/2 objects all  columns exported Custom profile files are found quickly by clicking: 

Enable 'Allow subdissector to reassemble TCP streams' in Preferences > Protocols > TCP Help > About Wireshark > Folders tab  

Edit Menu Personal configuration   > /profiles

Edit > Copy  - copy contents from Packet Details fields (R-Click in Packet List or Details)

Edit > Find Packet (Ctrl-F) by Hex value by String Wireshark profile configuration files:

by Display Filter format (no '0x' needed) in Packet List | Details | Bytes Capture Filters: cfilters (these are all 

will find any Coloring Rules: colorfilters text-editable)

occurrence of Decode As settings: decode_as_entries

the value Display Filters: dfilters

Preferences: preferences

Ctrl-N: Next GeoIP data files path: geoip_db_paths  (if configured)

Ctrl-B: Prev Recent changes: recent  (do not modify)

Edit > Mark | Unmark - highlights w/ Black background / White font - easier to find again preferences includes Filter Expression Button settings

Edit > Ignore | Unignore - eliminate extraneous packets hard to eliminate w/ filters You can ZIP a custom profile directory and share it

Save trace w/o Ignored pkts - select 'Remove Ignored packets' in Export Specified Packets see also: Global configuration dir for default files

Edit > Time Reference (Ctrl-T) - measure time from a specific packet to other pkts Click in the Profile section of the 

Can be used multiple places - click Reload icon to reset - this is a temporary setting Status Bar to select/change profiles

Edit > Packet Comment (also R-Click from Packet List) - annotate packets with notes R-Click in Profile section to select

Comments appear in Packet Details above the Frame meta data - highlighted in Green Manage Profiles 

Also listed in Analyze > Expert Info > Packet Comments tab. Must save trace as pcap-ng

Wireshark Quick Reference

WS 101 - Features & Functions

© 2014 PacketIQ Inc. WS v1.10 v1.1      1



Features & Functions:   Edit & View Wireshark Preferences 
Edit > Preferences (Ctrl-Shift-P) - Set/control all the settings for the current profile Edit > Preferences

View Menu Ctrl-Shift-P

View > Time Display Format Preferences Icon

These settings only affect / work with

'Time (format as specified)' field types You can set different

The two most useful time columns: preferences for each

'Rel Time' column:   progressive time custom profile

Seconds Since Beginning of Capture

Microseconds 0.123456 Preferences settings are

stored in the preferences

'Display Time' column:   data flow times file in each profile dir

Seconds Since Previous Displayed Packet

Microseconds 0.123456 Recommended Preference Settings:

User Interface - Maximum recent filters: 10   files: 10

View > Name Resolution Layout : Pane 1: Packet List   Pane 2: Details   3: Bytes

Resolve Name  - one-time DNS lookup Columns : Add | Remove | drag to move*

Manually Resolve Name  - enter hostname (temp) Font and Colors :  Lucida Console Normal | 8

MAC Layer  - NIC manufacturers (enable)

Transport Layer  - services by port #'s (enable) Capture - set Default interface & Capture as pcap-ng

Network Layer  - IP addresses to host names

works with Use External Network Name Resolver , as follows: Filter Expressions - Add | Remove | drag to move*

Network Layer + External Resolver: does reverse PTR lookups - creates DNS traffic

Network Layer - External Resolver - use hosts file in Wireshark program or profile directory Name Resolution - disable Resolve network (IP) Addr

Network Layer disabled +/- External Resolver - no IP to host name resolution GeoIP database directories

These are temp settings - use Preferences > Name Resolution to make permanent

Colors   Auto-Scroll Protocols - settings for every protocol

View > Colorized Packet List - turn coloring rules / colorization on/off Type sequential letters to quickly select (Ex: 'T' 'C' 'P')

View > Auto Scroll in Live Capture - On/Off (turn Off for busy captures)

HTTP : Add TCP ports to recognize as HTTP traffic

View > Zoom In | Out | Normal ( Ctrl +  |  Ctrl -  |  Ctrl = ) - adjust font size

IEEE 802.11 : Add / edit Wireless Decription keys

View > Resize All Columns (Ctrl-Shift-R) - auto-size Packet List columns Resize

IPv4 : Validate IPv4 checksum if possible (disable)

View > Displayed Columns - lists all columns & allows turning the display of each On / Off Enable GoIP lookups (enable)(if used)

View > Expand Subtrees (Shift - Right) These controls affect the expansion / collapse IPv6 : Enable GeoIP lookups (enable)(if used)

View > Expand All (Ctrl - Right) of various levels of protocol headers to show / 

View > Collapse All (Ctrl - Left) hide data fields in the Packet Details pane RTP : Allow subdissector to reassemble RTP streams

View > Colorize Conversation (Ctrl - 1 thru 9 & 0) - temporarily  make specific SMB : Reassemble SMB Transaction payload

conversations more visible. Click on any packet in a conversation (in Packet List) & apply Disable to measure First Byte response times

View > Reset Coloring 1-10 (Ctrl Space) - removes conversation coloring Enable to support exporting SMB objects

View > Coloring Rules - brings up Coloring Rules editor Edit Coloring Rules TCP : Validate TCP checksum if possible (disable)

Allow subdissector to reassemble TCP streams
View > Reload  - reloads capture file  / refreshes display Reload Disable to measure First Byte response times

Go Menu Enable to support exporting HTTP objects

Back - Forward - move to / from packets Relative sequence numbers (enable)

in a reassembled PDU group Track number of bytes in flight (enable

Calculate conversation timestamps (enable)

Go to Packet… - go to specific Pkt #

UDP : Validate the UDP checksum if possible (disable)

Go to Corresponding Packet - jump to

a packet selected from a Reassembled PDU * Easier to add / edit / move from the Packet List pane

list in the Packet Details pane Capture > Interfaces (Ctrl I) View / select intf(s)

Previous / Next Packet in Conversation

move between packets in a conversation

Capture Menu
Capture > Interfaces (Ctrl I)  see next frame

Capture > Options (Ctrl K) - see next page for details Select interface(s) to capture from (can do multiple)

Capture > Start (Ctrl E) Click the IP header to toggle IPv4 / IPv6 addresses

Capture > Stop (Ctrl E) (helpful for identifying a desired / configured interface)

Capture > Restart (Ctrl R) - new capture using the same Packets & Packets/s counters identify active intfs

interfaces and options - quick recover from a bad 1st capture

Capture > Filters… - see next page for details Interface Details offer a great deal of information

Capture > Refresh Interfaces - refresh interfaces & counters Options button opens the Capture > Options window
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Capture Options

Capture > Options (Ctrl K) - select capture interfaces, filters, and options Manage Interfaces

Local Interfaces

Select interface(s) to capture from Hide unuseable interfaces to avoid confusion

IPv6 & IPv4 addresses are displayed Remote Interfaces

List / Hide remote agent interfaces

Select or enter/edit Capture Filters (sidebar) Add - IP Addr & Port of remote rpcapd.exe agt

This example captures pkts to/from 10.1.1.125

Specify Capture Files location (Browse)

Provide a file name and location; if saving 

multiple files, specify the leading file name - 

Wireshark will append a date-time stamp to the

end of each file. Be sure to add a file extension

Display Options

Use promiscuous mode on all intfs - enable Update list of packets in real time - enable

Use pcap-ng format - enable Automatically scroll during live capture - enable

Hide capture info dialog - enable

Use multiple files - if you want to save a set of 

files, enable this then select the Next File every options by file size and/or time, optionally set a Name Resolution

Stop capture after (x) files, and/or Ring buffer with (x) files. Ring Buffer use will save (x) number of Resolve MAC addresses - enable

on-going files, discarding the oldest file every time a new one is started Resolve network-layer names - disable

Resolve transport-layer name - enable
Stop Capture Automatically After… to stop after (x) packets or by file size and/or time Use external network name resolver - disable

Features & Functions:   Analyze Capture Filters

Analyze Menu  See wiki.wireshark.org/CaptureFilters for more examples

Analyze > Display Filters - see side panel next page

Analyze > Display Filter Macros - mechanism to create shortcuts for complex filters

These next three features act on a selected field in the Packet Details pane:

Analyze > Apply as Column - create a new column in the Packet List

Analyze > Apply as Filter - create a Display Filter

Analyze > Prepare a Filter - prepare  (don't apply) a Display Filter

Analyze > Enable Protocols - enable/disable protocol dissectors

Analyze > Decode As… - decode a non-standard port as a

specific protcol. Typically, choose the Transport port # to be

decoded and the appropriate protocol to decode-as. You can

use Edit > Preferences > Protocol | <protocol> to set this

Click 'Clear' to eliminate entries. These are temp settings - Capture Filter Syntax & Examples

they are lost when closing Wireshark or changing profiles Hosts & Networks host host , src host, dst host

Analyze > User Specified Decodes… - Clear or Save decode settings in current profile ether host, ether src, ether dst gateway host host

net net/cidr , net net  mask mask

Analyze > Follow TCP / UDP / SSL Stream host 10.1.1.125 ether host 00:1c:25:99:db:85

VERY useful for inspecting commands and data exchanged wlan host ehost wlan host 00:21:6a:86:0b:c2

between clients and servers during a conversation w/o having net 10.1.1.0/24 or net 10.1.1.0 mask 255.255.255.0

to view data payloads across multiple pkts in a stream host <hostname> host www.packetiq.com

Can print or save a conversation to a separate capture file gateway host host (host name must be resolvable)

captures pkts to/from the hardware address of a gw

Analyze > Expert Info - one of the most useful features of Wireshark (typically a def router) but not the IP address of that gw

Errors - packet / dissector errs Ports & Protocols port, dst port, tcp port, tcp src,

udp port, udp dst arp, icmp, ip, udp, tcp, http

Warnings - unusual application port 80  (TCP or UDP port 80) DNS = port 53

and/or transport layer events - not arp and port not 53 (no ARP & DNS)

Out of Order packets, ACKed DHCP = port 67 & 68

segment that wasn't captured IPv6 ip6, icmp6 (replaces ARP & DNS)

(an indication of pkt loss), etc. DHCPv6 = port 546 & 547

Operators / Logic

Notes - additional application / =   !=   >   <   >=   <=   !   not   &&   and   ||   or

transport info, incl'd processes

for events that were reported in Other Filters / Examples

 a Warning - Duplicate ACKs, len <= length , len >= length len <= 128

Fast Retransmissions, etc. vlan [vlan_id]   (IEEE 802.1Q VLAN pkts) vlan 1

not multicast and not broadcast

Chats - info about workflows, A high count of Duplicate Acks (#xx)

like TCP session setups / teardowns, GETs, etc. can indicate a high latency network path, Offsets  [# bytes from start of header, # bytes to match]

but check to see how long the recovery ip[2:2] > 576 (IP pkts > 576 bytes) ip[1:1] > 0

Details - sequential list of Expert Info events period really was (delta time from 1st to tcp[0:2] = 80 (TCP src port = 80) (DiffServ != 0)
Packet Comments - listed by Packet # last Dup ACK) - it may not be that long Use capture filters sparingly so you don't miss anything!
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Features & Functions:   Statistics Display Filters

Statistics Menu Analyze > Display Filters - select, create, delete filters

Statistics > Summary - capture summary & stats & Display Filter stats  (if applicable)

Statistics > Comments Summary - summary + Capture & Pkt Comments - can be copied To create a new filter

Statistics > Show Address Resolution - hosts data for current trace file (if Name Res on) enter the display filter

name and filter string

and then click 'New'

Statistics > Protocol Hierarchy - packet & byte counts & percentages

by protocol. Useful for detecting anomalies / suspect traffic) - look for unusual protocols Display filters are saved

in the dfilters  profile file

Statistics > Conversations - conversation pairs + packets / bytes / time / rates by protocol

Display Filter Toolbar - enter/edit - Clear/Apply/Save

Filter opens the Display Filters window shown above

Expression... opens a window that walks you through

creating a display filter - you can see all the possible

filters and their extensions w/ descriptions

Save a display filter as a Filter Expression Button for

quick and easy us of filters - very handy!!  Configs for

Filter Expression Buttons are saved in preferences  files

Useful Display Filters arp bootp dns

dhcp6 snmp smb smb2 icmp rtp

ip ipv6 udp tcp http sip

Ethernet - station pairs by MAC Addr A VERY useful tool for identifying & filtering ip.addr==10.1.1.125 && ip.addr==192.168.1.115

IPv4 - host pairs by IP Addr or hostname on conversations of interest from a capture: tcp.port==80 tcp.stream==1

TCP - TCP stream conversations by port 1. Select IPv4 - Click the Bytes column twice - Extended filter options are available for each protocol

UDP - UDP stream conversations by port     Top Talkers by IP Addr will top the list Use Wireshark's auto-complete feature to list filters; 

WLAN - WLAN conversations by STA Addr 2. ID the conversation of interest by name / IP type a protocol abbreviation and then a period to view

Pay attention to: port #'s / services used, 3. R-Click, select 'Apply as a Filter', 'Selected', and select a filter:  Example: tcp.analysis.xxxxxx

Pkts/Bytes A-B (relative traffic volumes),     'A<->B' to apply a display filter for this conv There are ip.geoip display filters - for example:

Rel Start - when did a thread start?, 4. Inspect - if this is the desired conversation, ip and not ip.geoip.country == "United States"

bps A->B, A<-B - impact on the network?     save to a new file: File > Export Specified Packets Show nodes North of New York: ip.geoip.lat > 41

Name resolution - turn on/off to ID host pairs by IP or hostname (if resolution info available)  See http://www.wireshark.org/docs/dfref/ for more info

Limit to display filter - inspect TCP/UDP conversations related to a filtered IP host pair Packet Lengths
Most common data transfer methods use TCP/IP

Statistics > Endpoints - displays stats like Conversations, but for single hosts on Ethernet 802.3 networks supporting 1518-byte max

IPv4/v6 tabs support GeoIP mapping - Click 'Map' -> frame sizes and a 1500-byte MTU (default in routers)

Country, City, & AS #'s for each host based on IP Addr

Setup GeoIP

1. Create a 'MaxMindGeoIP' directory on your hard drive

2. Open http://dev.maxmind.com/geoip/legacy/geolite/

3. Click / save the binary / gzip files for Country, City, & ASN (IPv4 & v6); unzip to .dat files

4. Edit > Preferences > Name Resolution | GeoIP database directories 

5. Click New - navigate to MaxMind dir - choose 'Other…' - click 'Open' 

(its easier to enter the path in the 'Location' field or edit geo_db_paths)

Statistics > Packet Lengths - useful for determining nominal pkt sizes

Can be used with a Display Filter setting. There shouldn't be any pkts <

40-79 bytes. 9000 byte Jumbo Packets may be enabled on 10GE intfs

Ethernet (MAC) header + IP header + TCP header +

Statistics > IO Graph - this is another of the MOST useful Wireshark features Frame Check Sequence (FCS) = 58 bytes

This Filter IO Graph example reveals bi-directional peak application demands in bits-per-sec 1518 - 58 = 1460 byte Maximum Segment Size (MSS)

You can click on a point in the IO Graph to go to that packet in the Packet List IO Graph Options
X axis intervals: IO Graph Styles

Set Tick interval .001, .01, .1, 1, 10 sec, 1 min, 10 min

to smaller units to Y axis settings:

provide increased Packets - Bytes - Bits /Tick & Advanced

per-pkt resolution Scale - Auto, 10 to 2 Billion, logarithmic

Smoothing - plots a moving avg of data

Set Y Axis Unit to Advanced Options:

Advanced for add'l SUM(*) Adds values of a field for a tick

functionality - see MIN(*) Min value during a tick interval

panel on right for AVG(*) Avg value during a tick interval

more options MAX(*) Max value during a tick interval

COUNT FRAMES(*) # of frames containing a field

Copy the IO graph or characteristic seen during the tick interval

data points to save COUNT FIELDS(*) # of occurences of a field or 

in .csv format or characteristic seen during the tick interval 
Save an image LOAD(*) Measures response time fields only
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Features & Functions:   Statistics & Telephony TCP Stream Graphs

Statistics Menu - Cont'd Statistics > Stream Graphs - one of the more

Statistics > Conversation List - another way to open a Conversations window impressive but least understood / utilized features

Statistics > Endpoing List - another way to open an Endpoints window (w/ IPv4/v6 GeoIP) For ALL of the TCP Stream Graphs:

Statistics > Service Response Time - tables of min, max, avg service response times 1. Click a packet in the Packet List for the direction the

for services such as SMB2. R-Click & build procedure filters -> data is flowing (a server pkt for a server->client transfer

Statistics > ANCP - Access Node Control Prot (DSL access) 2. Statistics > TCP Stream Graph > <any graph>

Statistics > BACnet - Building Automation & Control Network If a graph is blank, select a packet in the other direction

Statistics > BOOTP-DHCP - list of packets by type !! Each graph is only for the selected packet's flow

Statistics > Collectd - info on Collectd daemon stats traffic Or open two graphs - one for each direction 

(collector for an open source system performance project)

Statistics > Compare - supports comparing trace files from both ends of a file transfer 3. Click on an area of interest and use keyboard '+' & '-'

based on IP IDs. Merge files w/ Mergecap then open & Compare (not reliable this version ) keys to zoom In/Out  (Click/drag w/ mouse to zoom in)

Statistics > Flow Graph - similar to a 'Bounce Diagram' - displays SMB2 or HTTP flows

between nodes with elapsed time, Req/Resp and data flow info. Can be exported to txt file 4. Use keyboard arrow keys

Statistics > HART-IP - Highway Addressable Remote Transducer over IP stats  to go Left/Right / Up/Down

Statistics > HTTP - Packet Counter - packet distribution 5. Clicking a point in the

Statistics > Requests - by HTTP host & list of requests graph takes you to that pkt

Statistics > Load Distribution - Reqs/Resps by Server

6. Along with any graph a

Statistics > ONC-RPC - Min/Max/Avg service response Control window will appear - 

times for the ONC variation of Remote Procedure Call select a desired graph 

Statistics > Sametime - stats for Lotus Notes Sametime from the Graph Type tab

Round Trip Time

Statistics > TCP StreamGraph - see panel on right latency time between a

TCP data packet and 

Statistics > UDP Multicast Streams - multicast source, destination, port, BW, & burst info a related ACK packet.

Stream analysis / Investigate spikes or

burst parameters other anomalies

can be set.

Multicast stream Throughput

sources include Like an IO Graph but

OSPF, IGMP, & with dots (vs lines) and

video streams graphed in Bytes / sec

This graph reflects a 

high latency path w/

Statistics > WLAN Traffic SMB2 transfer effects

Provides WLAN traffic statistics incl'd

BSSID, Channel, SSID, % Packets, Time/Sequence

and summary stats of frame types (Steven's style)

Selecting a BSSID / Ch / SSID network Plots sequence #'s as

provides statistics for that network: they increase during a

address, % Packets, data sent/rcvd, data transfer. Ideal plot

and management frame counts is lower left to upper

right in a smooth line.

The 'rate' in stats below is packets / ms

Statistics > IP Destinations - IP dest addresses & pkt counts, rate, & % by protocol & port

Statistics > IP Addresses - IP addresses w/ total (src + dest) packets, rate, & % counts Time/Sequence
Statistics > Protocol Types - total packet counts, rate (ms), & percents by protocol (tcptrace style)

Telephony Menu Protocols for cellular radio & VoIP ntwks, SS7, etc. Also plots SEQ #'s but

Telephony > ANSI - BSMAP, DTAP, & MAP Operation A-Interface message stats with more info. TCP 

Telephony > GSM - Global System for Mobile Communications A-Interface msg stats segments are plotted

Telephony > H.225 - H.225 Message & Message Reason counters in an  I - bar format - 

Telephony > IAX2 - Inter-Asterisk stream analysis taller bars contain more 

Telephony > ISUP - ISDN User Part message Count Rate (ms) & percentages data. Horizontal is time, vertical is Byte-based Seq #s

Telephony > LTE - Long Term Evolution protocol MAC & Radio Link Control stats & graphs Grey line is the window size - when I bars reach this

Telephony > MTP3 - Message Transfer Part3 Message Signal Unit stats line you have a Zero Window (no data flow) condition.

Telephony > RTP > Show All Streams - lists & displays stats for RTP steams Window Scaling

Plots calculated window

size in each pkt sent.

To use select an ACK

pkt from the host that

is receiving data. 
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Features & Functions:   Telephony & Tools & Internals Wireshark Help

Telephony Menu - Cont'd

Telephony > RTP > Show All Streams - Cont'd RTP = Real-Time Transport Protocol

SSRC is the Synchronization Source Identifier that ID's a RTP stream timestamping source

Pb? indicates a problem in the RTP stream - pkt loss & errors, out of order seq #'s, etc.

Select Fwd & Revs streams, click Analyze to open Stream Analysis window for those streams

Telephony > RTP >  Stream Analysis - displays per-pkt performance stats for RTP flows

Pkt #, Seq #, time delta, jitter, skew,

IP bw (kbps), end of silence marker,

status, & summary stats at bottom 

for Fwd & Reverse directions. Help > Contents (F1) - Wireshark User's Guide

Click Save payload & save both Help > ManualPages - man-style html help pages

channels in .au format for playback. Help > Website http://www.wireshark.org

Click Save as CSV to save stats in Help > FAQ's http://www.wireshark.org/faq.html

csv format for analysis in Excel®. Help > Ask (Q&A) http://ask.wireshark.org

Help > Downloadshttp://www.wireshark.org/download.html

Click Graph to visualize per-packet jitter - adjust Tick interval & Pixels / tick for best display Help > Wiki http://wiki.wireshark.org

Click Player then Decode to launch audio player > Sample Captures http://wiki.wireshark.org/SampleCaptures

Help > Check for Updates… - online version check

Help > About Wireshark… > Wireshark - current

 version & info on your workstation! Even versions are

stable releases, odd versions are development

Click to select Fwd & Rev streams

then Play to listen to call audio ->

Telephony > RTSP > Packet Counter - displays Real Time Streaming Protocol request

& response pkt Count Rate in pkts/ms & Percent. Resp pkts listed by resp code categories

SCTP = Stream Control Transport Protocol - transport layer protocol w/ elements of both UDP & TCP Help > About Wireshark… > Authors - all of the

Telephony > SCTP - Analyze & Show Associations (connections), (data) Chunk Counter developers who have made this fine tool possible

Telephony > SIP - Session Initiation Protocol stats & request methods Help > About Wireshark… > Folders - very handy!

Personal profile files are in Personal configuration folder

Telephony > SMPPOperations - Short Message Peer Protocol stats Command-line utilities in Program folder - GeoIP path
Telephony > UCP Messages - Universal Computer Protocol stats Double-click a link to open that folder

Main Toolbar

Telephony > VoIP Calls - lists VoIP calls in a capture. Click Flow to  GET IN THE HABIT OF USING THESE - Saves Time!

open a Graph Analysis. Click Player to open the RTP player. Capture Toolbar Icons

Restart Capture - quick

recover from bad 1st capture

List Interfaces – Capture Options – Start – Stop – Restart Capture

Trace File Toolbar Icons
Telephony > WAP-WSP… - Wireless Application Protocol-Wireless Session Protocol stats Many temp settings can be 

Tools Menu cleared by Reload File

Tools > Firewall ACL Rules - creates Open File - Save File - Close File - Reload File

ACL rules used by firewall products to

block or allow traffic based on various Navigation Toolbar Icons

characteristics found within packet traces. Back returns to

Click on a packet or field and launch, then last pkt located

Select Product and Filter options Find - Go Back - Fwd – Jump To – Go to First | Last Pkt

Tools > Lua - Lua is "a powerful, fast, lightweight, embeddable scripting language" added to Color - Scroll - View Toolbar Icons

Wireshark for prototyping and scripting, writing dissectors, post-dissectors, and 'taps'

Internals Menu Pkt Coloring - Auto-Scroll      Zoom In | Out | 100% | Resize

Internals > Dissector tables - variables/parameters that reflect defined standards for a 

protocol in each dissector. See TCP & UDP port integer tables, Heuristic svcs/abbreviations Filter Editors - Color Rules - Configuration - Help

View/edit filters & colors

Internals > Supported Protocols - exhaustive list of all protocols supported in Wireshark. Set Preferences

Display Filters Fields tab lists ALL of >100,000 protocol and packet type fields recognized Capture Filter Editor - Display Filter Editor

by Wireshark & can be used to create Display Filters - scroll right to see add'l type fields Coloring Rules Editor - Preferences - Help
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Wireless Analysis Wireless Adapters

View > Wireless Toolbar to enable / view the toolbar Wireless capture on

on ANY channel w/o

association requires 

Controls: Note: 802.11 adapters must be set to monitor mode  (rfmon mode ) - not all can be AirPcap adapters like

802.11 Channel to capture - Channel Offset w/AirPcap N/NX Adapters for a "wide channel" AirPCap NX USB 802.11a/b/g/n (capture + injection)

FCS Filter: All Frames - Valid Frames - Invalid Frames only Catalog:  http://www.cacetech.com/products/catalog/

Decryption Method - None, Wireshark, Driver (AirPcap driver) AirPcap Driver: Can use up to 3 adapters for Ch 1+6+11

Advanced Wireless Settings - offers the same   https://support.riverbed.com/content/support/software/cascade/airpcap.html

options you can set from the toolbar, plus: Bug Fix: if the Wireless Toolbar stays greyed out with

A button to 'Blink LED' on the AirPcap adapter an AirPcap adapter installed - open Capture Options,
Set the Capture Type to: Dbl-Click on the AirPcap entry, click OK, then Start

802.11 Only Packet List Columns

802.11 + Radio (default) - prepend a 'Radiotap' Column Header R-Click Menu

pseudoheader to each frame in Packet Details pane R-Clk > Sort options are quicker to

802.11 + PPI = prepend Per-Packet Information pseudoheader in Packet Details Pane do by just clicking a column header

Include 802.11 FCS in Frames (on by default) multiple times

Decryption Keys… - Add / Edit / Delete keys R-Clk a column header and select

Decryption Mode - Driver, Wireshark, None Align Left - Center - Right or 

(select Wireshark to avoid saving keys in registry) Resize Column

Add Decryption Key - Type, Key, SSID (not labeled) You can click & drag a column to

Type: WEP - parsed as WEP key another location in the Packet List

(wep:a1:b2:c3:d4:e5)

SPA-PWD - pswd + SSID R-Clk > Column Preferences brings up Preferences 

(wpa-pwd:MyPassword:MySSID) window for selecting / customizing columns

WPA-PSK - raw pre-shared key (wpa-psk:01020304050607…5647392)

Right-Click Menus R-Clk > Edit Column Details allows modification of the

Many Wireshark tasks can be completed much more quickly using Right-Click menus Title, Field type, Field name, and occurrence (for filters

Different R-Clk options are available in Packet List, Packet Details, & Packet Bytes panes, that match more than one field in a packet)

depending on where (which field) you R-Click from. All of the options in R-Clk menus are

covered in previous sections, but a few specifics apply: Packet List Right-Click Menu R-Clk > Displayed Columns list all available columns,

The Display Filter string prepared when you Right-Click which are currently displayed, and the ability to select

and select Apply as Filter or Prepare a Filter depends on

the specific packet and field you clicked from R-Clk > Hide Column hides (but does not delete) the

selected column from being displayed in Packet List
You can R-Clk > Colorize Conversations or create a RC > Remove Column deletes a column permanently

New Coloring Rule - but you have to select View > Reset Status Bar

Coloring 1-10 (or Ctrl-Space) to remove the coloring

Right-Click > Copy options vary depending on the pane: Expert Info Button - click to bring up Expert Infos

Packet List Pane Packet Details Pane Button color indicates highest analysis level:

Trace File Annotation Button - Add / Edit / Cancel

comments about the entire trace file

R-Clk > Protocol Preferences offers a selection of the File Information Column - path/directory & file name, 

preferences options for the highest layer protocol in that pkt file size, & packet capture duration

Packet Details R-Click Menu

R-Clk on a protocol layer header & select Expand Subtrees

to expand all of the headers UNDER that protocol layer, Packet Information Column - displays Packet counts:

or Expand All / Collapse All to affect all the protocol layers Total - Displayed - Marked - Dropped (during capture)

R-Clk > Apply as Column in Packet Details is a quick way

to add a Pkt List pane column of the selected field values Profile Column - Click to select profiles / Right-Click to

select Manage Profile options

R-Clk > Wiki Protocol Page, Filter Field Reference, & Profile Selection Menu

Protocol Help offers info based on the protocol/field selected

Packet Bytes R-Clk Menu Profile Management Menu

R-Clk > Hex View displays Packet

Bytes contents as Hex octets &

their ascii derivative (if possible)

R-Clk > Bits View displays each

packet byte in 1's & 0's
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Working with Time Remote Captures (Windows only)

There are several Wireshark time fields available  Install WinPcap & start rpcapd.exe on remote machine

Absolute (actual capture date/times) CMD window - navigate to WinPcap install directory

Absolute date & time - actual capture date and time based on the time zone of analysis host rpcapd -n (C:\Program Files (x86)\WinPcap\ )

Absolute time - actual capture time (no date) based on time zone of analysis host You can use a -l (lower case 'L') with rpcapd to specify

which hosts can connect.      rpcapd -h  for help

Relative (to start of capture)

Relative time - time from the first packet in a trace file Wireshark:

Relative time (conversation) - time from the first packet in the trace file for the conversation Capture Options >

Time (format as specified) - this setting displays a value set using View > Time Display Format Manage Interfaces >

Remote Interfaces >

Delta (from previous frames) Add - enter remote

Delta time (frame.time_delta) - end of the current frame from the end of the prevoius frame machine's IP address & Port 2002 (default) - Ok - Close

Delta time (conversation) - end of one packet to the end of the next packet in a conversation Capture Options:

Delta time displayed - end of one packet to the end of next packet of displayed packets only Un-select unwanted interfaces - the desired intf will have

the correct IP address listed under the Interface ID

Wireshark saves a GMT/UTC offset value of the capture machine in the packet trace file, and Click Start - Click OK and ignore the capture buffer msg

converts the timestamps to the number of seconds since the UNIX 'epoch' - # of seconds since

Jan 1, 1970 @ 00:00:00 GMT. When the trace file is opened the GMT/UTC offset is again Be aware that captured packets are sent from the

applied to display the timestamps. If a capture from one time zone is viewed in another remote machine to the controlling Wireshark machine

time zone, the absolute date/time stamps will be off by the difference in the time zones.

Coloring Rules

Selecting Wireshark Time Displays Colorization can be an effective tool for identifying

You need to know when an event occurred in a capture and highlighting packets of interest. Wireshark has

Absolute Time: locating events related to user reports / logs predefined coloring rules in a default file (colorfilters).

Relative Time: how far into a capture an event occurred But… sometimes too many colors can be distracting.

Turn off most default rules, leave useful ones on or add

You need the delay between pkts in a conversation, especially responses to requests your own based on Display Filter syntax and your colors

Delta time: time between packets in a conversation

This example shows the differences between Abs, Rel, Frame Delta, and Displayed Delta times:

Abs Time steadily increases… as does Relative time GET / is request for a homepage

Frame Delta Time varies - is the difference between frames ACK comes 25.5 ms later

Delta Time Displayed is diff between displayed frames First Byte resp 137 ms after that

Also see: tcp.time_relative & tcp.time_delta times for TCP Total First Byte RT is 163 ms New / Edit / Delete - create, edit, or delete a rule

Create multiple time columns and Show / Hide as needed (with a network RTT of 19 ms) New/Edit: name, display filter string, fg and bg color

Enable 'calculate conversation timestamps' in TCP Preferences to support delta times Enable / Disable - turn a rule on/off w/o deleting it

Filter Expression Buttons Up / Down - change the rule order. Wireshark evalutes

One of the best new features in Wireshark - quickly apply & clear useful analysis filters coloring rules from top to bottom - first match is used,

1. Prepare & test a Display Filter so you should put more specific rules near the top

2. Click 'Save' on Display Filter Toolbar

3. Enter a button name - OK Import / Export - import or share coloring rule files

These are saved in your Personal Configuration Clear - remove all personal rules & revert to default rules

preferences  file. Edit this file manually to change the button order arrangement

Command Line Utilities Analysis Tips

Tshark or Dumpcap for packet captures Editcap to edit trace files -h for options 1. Turn off TCP releative sequence numbers to match

tshark -h  or  dumpcap -h  for options editcap [options] <infile> <outfile> captures from 2 or more locations by SEQ/ACK #'s

-D to get list of interfaces - use intf # in cmd [ <pkt #> [-<pkt #>] … (start @ Pkt # or range) 2. Turn off 'Allow subdissector to reassemble TCP

-f <capture filter> in BPF format -A <start time> -B <stop> (YYYY-MM-DD hh:mm:ss) streams' with HTTP to get 1st Byte response times

-i <interface name or #> -d remove duplicate packets (def window = 5) 3. http.response.code > 399 to see HTTP err msgs

-w <outfile> (pcap format) -D <dup window> (0 to 1000000 pkts) 4. Disable Checksum Validations to eliminate false errs

Ex:  tshark -i 2 -w tcapture.pcap -w <dup time window> (rel sec e.g. 0.000001) 5. Clear Win DNS cache:  ipconfig / flushdns

dumpcap -i 2 -f "host 192.168.1.116" -t <time adjustment> - in rel sec e.g. -0.5 | 60     Linux: restart nscd (name service cache daemon)

-b filesize:100000 -b files:3 -w capture.pcap -c <pkts per file>      -i <sec per file> 6. Clear Win arp cache (elevated CMD): arp -d -a

Ctrl-C to stop capture Ex: split a large trace file into multiple smaller 7. WS frame dissector calcs / adds frame meta-data:

Mergecap to merge packet trace files files of 600 seconds: (outfiles will be #'d) frame # & timestamp - frame length & captured len

mergecap -h for options editcap -i 600 infile.pcap outfile_.pcap coloring rules applied & coloring rule string

mergecap -w <outfile> <infile> <infile> [<inf… Capinfos to get trace info -h for options © 2014 PacketIQ Inc.  All rights reserved.
-s <snaplen> - truncate to <snaplen> bytes capinfos [options] <infile> This guide is provided with PacketIQ Wireshark 101:

Ex: mergecap -w outfile.pcap infile1.pcap -c  # of pkts   -d  data size   -u  capture dur (s) Features & Functions training.   WS 201: Performance 

infile2.pcap infile3.pcap -s 128 Ex: capinfos -cdu MyCapture.pcap Analysis and WS 301: Packets & Protocols training is

Wireshark and the "fin" logo are registered trademarks of the Wireshark Foundation also available. Contact info@packetiq.com or call us at

Excel is a registered trademark of Microsoft +1 321-888-2288 www.packetiq.com | Training
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